6.0.0-git
2019-04-23

[#8304] Add hunspell support to Horde_SpellChecker
Summary Add hunspell support to Horde_SpellChecker
Queue Horde Framework Packages
Queue Version Git master
Type Enhancement
State Assigned
Priority 1. Low
Owners chuck (at) horde (dot) org
Requester torlasz (at) net (dot) sote (dot) hu
Created 2009-05-23 (3622 days ago)
Due
Updated 2009-06-04 (3610 days ago)
Assigned 2009-06-04 (3610 days ago)
Resolved
Milestone
Patch No

History
2009-06-04 03:16:21 Chuck Hagenbuch Comment #3
Summary ⇒ Add hunspell support to Horde_SpellChecker
Reply to this comment
2009-06-04 03:12:48 Chuck Hagenbuch Assigned to Chuck Hagenbuch
State ⇒ Assigned
 
2009-06-04 03:12:36 Chuck Hagenbuch Comment #2
Version ⇒ Git master
Queue ⇒ Horde Framework Packages
Reply to this comment
I'll try and take a look at adding this to the SpellChecker library
2009-05-23 13:04:27 torlasz (at) net (dot) sote (dot) hu Comment #1
Type ⇒ Enhancement
State ⇒ New
Priority ⇒ 1. Low
Summary ⇒ Using the hunspell spelling checker
Queue ⇒ IMP
Milestone ⇒
Patch ⇒ No
New Attachment: hunspell.php Download
Reply to this comment
I tried to add hunspell support to IMP 4.3.4. The system is CENTOS 5 
linux, using Horde 3.3.4, hunspell-1.2.7-5 rpm (built from Fedora 10 
source rpm). Attached you can find the php program I made based on 
aspell.php. (Note: I am not a php programmer)



I set the IMP config like this:

$conf['spell']['params']['path'] = '/usr/bin/hunspell';

$conf['spell']['driver'] = 'hunspell';



Putting ASCII chars into the message window, using -d en_EN, -i utf-8 
I am getting back from the hunspell reading the pipe only the first 
greeting line of hunspell:

@(#) International Ispell Version 3.2.06 (but really Hunspell 1.2.7)



Nothing more. However, if I run the relevant lines from the code as a 
CLI php program (as user apache), I get back the expected response. 
That's something I don't understand. The hunspell program gets the 
input from Horde (I checked that running through a simple shell script 
with tee-ing input and output of hunspell).

Also the same hunspell binary worked perfectly with Horde/IMP 
3.1.5/4.1.5 on the same machine.



It would be really nice to be able to use hunspell with the current 
IMP (quite a few languages can't use aspell). It used to work until I 
upgraded to Horde/IMP 3.3.4/4.3.4, and my users liked this feature.


Saved Queries