6.0.0-git
2018-12-15

[#6590] Blank page when selecting alternative calendar
Summary Blank page when selecting alternative calendar
Queue Horde Base
Queue Version HEAD
Type Bug
State Stalled
Priority 1. Low
Owners
Requester jochem (at) mondrian (dot) nl
Created 2008-04-10 (3901 days ago)
Due
Updated 2016-04-27 (962 days ago)
Assigned 2009-01-29 (3607 days ago)
Resolved 2009-09-17 (3376 days ago)
Milestone
Patch No

History
2009-09-17 17:31:32 patrickdk (at) patrickdk (dot) com Comment #22 Reply to this comment
From bug 8580.

I tried this patch, and it fixes the problem on all my test machines.
2009-09-17 17:15:54 Michael Slusarz Comment #20
State ⇒ Stalled
Reply to this comment
Michael bangs head against the wall multiple times. Due to me 
misreading this page:

https://prototype.lighthouseapp.com/projects/8886/tickets/90-cloneposition-problem-in-ie7

this *wasn't* fixed in 1.6.1 either.  Although I can't reproduce on my 
installations, the core problem should remain because that prototypejs 
bug has not yet been closed.  So we need to repatch again.



This is my fault again (although, in my defense, I specifically tested 
this when updating to 1.6.1 and it worked fine for me).
2009-09-17 17:15:32 CVS Commit Comment #19 Reply to this comment
Changes have been made in CVS for this ticket:

Bug: 6590
Unbelievable.
http://cvs.horde.org/diff.php/chora/js/prototype.js?rt=horde&r1=1.14.2.3&r2=1.14.2.4&ty=u
http://cvs.horde.org/diff.php/chora/js/src/prototype.js?rt=horde&r1=1.12.2.3&r2=1.12.2.4&ty=u
http://cvs.horde.org/diff.php/gollem/js/prototype.js?rt=horde&r1=1.12.2.3&r2=1.12.2.4&ty=u
http://cvs.horde.org/diff.php/gollem/js/src/prototype.js?rt=horde&r1=1.10.2.3&r2=1.10.2.4&ty=u
http://cvs.horde.org/diff.php/horde/docs/CHANGES?rt=horde&r1=1.515.2.561&r2=1.515.2.562&ty=u
http://cvs.horde.org/diff.php/horde/js/prototype.js?rt=horde&r1=1.11.2.8&r2=1.11.2.9&ty=u
http://cvs.horde.org/diff.php/horde/js/src/Attic/prototype.js?rt=horde&r1=1.7.2.6&r2=1.7.2.7&ty=u
http://cvs.horde.org/diff.php/imp/js/Attic/prototype.js?rt=horde&r1=1.21.2.9&r2=1.21.2.10&ty=u
http://cvs.horde.org/diff.php/imp/js/src/Attic/prototype.js?rt=horde&r1=1.13.2.6&r2=1.13.2.7&ty=u
http://cvs.horde.org/diff.php/ingo/js/Attic/prototype.js?rt=horde&r1=1.4.2.7&r2=1.4.2.8&ty=u
http://cvs.horde.org/diff.php/ingo/js/src/Attic/prototype.js?rt=horde&r1=1.4.2.6&r2=1.4.2.7&ty=u
http://cvs.horde.org/diff.php/kronolith/js/Attic/prototype.js?rt=horde&r1=1.14.2.9&r2=1.14.2.10&ty=u
http://cvs.horde.org/diff.php/kronolith/js/src/Attic/prototype.js?rt=horde&r1=1.10.2.6&r2=1.10.2.7&ty=u
http://cvs.horde.org/diff.php/mnemo/js/Attic/prototype.js?rt=horde&r1=1.3.2.8&r2=1.3.2.9&ty=u
http://cvs.horde.org/diff.php/mnemo/js/src/Attic/prototype.js?rt=horde&r1=1.6.2.6&r2=1.6.2.7&ty=u
http://cvs.horde.org/diff.php/nag/js/Attic/prototype.js?rt=horde&r1=1.4.2.9&r2=1.4.2.10&ty=u
http://cvs.horde.org/diff.php/nag/js/src/Attic/prototype.js?rt=horde&r1=1.8.2.6&r2=1.8.2.7&ty=u
http://cvs.horde.org/diff.php/turba/js/Attic/prototype.js?rt=horde&r1=1.12.2.8&r2=1.12.2.9&ty=u
http://cvs.horde.org/diff.php/turba/js/src/Attic/prototype.js?rt=horde&r1=1.9.2.6&r2=1.9.2.7&ty=u
2009-09-16 16:47:24 Michael Slusarz Comment #18
State ⇒ Resolved
Reply to this comment
This was fixed with an upgrade to prototypejs v1.6.1.
2009-01-29 15:45:48 Chuck Hagenbuch Comment #17
State ⇒ Stalled
Priority ⇒ 1. Low
Reply to this comment
Stalling with the other bugs waiting for an official prototype patch.
2009-01-29 12:02:11 Jan Schneider Comment #16
State ⇒ Feedback
Reply to this comment
Why is this still assigned? Isn't the problem fixed now after we 
patched prototype again?
2008-12-10 18:05:34 Michael Slusarz Comment #15
Version ⇒ HEAD
Queue ⇒ Horde Base
State ⇒ Assigned
Priority ⇒ 3. High
Reply to this comment
*sigh* This bug was not fixed in prototype 1.6.0.3 despite some 
literature stating otherwise.  The previous patch has thus been 
applied to prototypejs v1.6.0.3.
2008-12-10 18:04:35 CVS Commit Comment #14 Reply to this comment
Changes have been made in CVS for this ticket:

http://cvs.horde.org/diff.php/chora/js/prototype.js?r1=1.14.2.1&r2=1.14.2.2&ty=u
http://cvs.horde.org/diff.php/chora/js/src/prototype.js?r1=1.12.2.1&r2=1.12.2.2&ty=u
http://cvs.horde.org/diff.php/gollem/js/prototype.js?r1=1.12.2.1&r2=1.12.2.2&ty=u
http://cvs.horde.org/diff.php/gollem/js/src/prototype.js?r1=1.10.2.1&r2=1.10.2.2&ty=u
http://cvs.horde.org/diff.php/horde/js/prototype.js?r1=1.11.2.6&r2=1.11.2.7&ty=u
http://cvs.horde.org/diff.php/horde/js/src/prototype.js?r1=1.7.2.4&r2=1.7.2.5&ty=u
http://cvs.horde.org/diff.php/imp/js/Attic/prototype.js?r1=1.21.2.7&r2=1.21.2.8&ty=u
http://cvs.horde.org/diff.php/imp/js/src/Attic/prototype.js?r1=1.13.2.4&r2=1.13.2.5&ty=u
http://cvs.horde.org/diff.php/ingo/js/Attic/prototype.js?r1=1.4.2.5&r2=1.4.2.6&ty=u
http://cvs.horde.org/diff.php/ingo/js/src/Attic/prototype.js?r1=1.4.2.4&r2=1.4.2.5&ty=u
http://cvs.horde.org/diff.php/kronolith/js/Attic/prototype.js?r1=1.14.2.6&r2=1.14.2.7&ty=u
http://cvs.horde.org/diff.php/kronolith/js/src/Attic/prototype.js?r1=1.10.2.4&r2=1.10.2.5&ty=u
http://cvs.horde.org/diff.php/mnemo/js/Attic/prototype.js?r1=1.3.2.6&r2=1.3.2.7&ty=u
http://cvs.horde.org/diff.php/mnemo/js/src/Attic/prototype.js?r1=1.6.2.4&r2=1.6.2.5&ty=u
http://cvs.horde.org/diff.php/nag/js/Attic/prototype.js?r1=1.4.2.7&r2=1.4.2.8&ty=u
http://cvs.horde.org/diff.php/nag/js/src/Attic/prototype.js?r1=1.8.2.4&r2=1.8.2.5&ty=u
http://cvs.horde.org/diff.php/turba/js/Attic/prototype.js?r1=1.12.2.6&r2=1.12.2.7&ty=u
http://cvs.horde.org/diff.php/turba/js/src/Attic/prototype.js?r1=1.9.2.4&r2=1.9.2.5&ty=u
2008-05-18 10:23:18 Jan Schneider State ⇒ Stalled
 
2008-05-05 19:33:14 Michael Slusarz Comment #12
State ⇒
Priority ⇒ 1. Low
Reply to this comment
Reopen - since at some point (hopefully) we won't need this patch anymore.
2008-05-02 21:18:45 Chuck Hagenbuch Comment #11
State ⇒ Resolved
Reply to this comment
Patch for the prototype bug has been applied to our CVS.
2008-04-18 17:54:29 john (dot) david (dot) dalton (at) gmail (dot) com Comment #10 Reply to this comment
Hello Michael , It looks like you are using an older version of YUI 
compressor, newer versions work with Prototype 1.6 and its use of the 
$super variable. You may also use a modified dean edwards packer found 
in ProtoSafe, or you can use the precompressed version in ProtoPack:

http://code.google.com/p/protosafe/downloads/list



The erroneous compression is whats causing the ajax-y related bugs 
because the ajax methods use the $super variable which was changed to 
something like "C" when you compressed it in the older verson of YUI 
compressor.



The element style error is related to that ticket: 
http://dev.rubyonrails.org/ticket/11473#comment:19
2008-04-18 04:43:12 Michael Slusarz Comment #9 Reply to this comment
Can anyone confirm that the prototype bugfix fixes this?
Verified that the prototype patch fixes this (and ticket 6602).
2008-04-11 18:49:05 Chuck Hagenbuch Comment #8 Reply to this comment
Can anyone confirm that the prototype bugfix fixes this?
2008-04-11 16:20:05 Michael Slusarz Comment #7 Reply to this comment
Almost 100% sure this is a prototypejs bug.  See:

http://dev.rubyonrails.org/ticket/11007

http://dev.rubyonrails.org/ticket/11473



Looks like it is fixed in 1.6.0.3 (which is not yet released).
2008-04-11 15:32:53 jochem (at) mondrian (dot) nl Comment #6 Reply to this comment
I can confirm that this also happens on IE6, and was happening before 
this IE7 started giving similar issues.
2008-04-11 15:20:27 Michael Rubinsky Comment #5 Reply to this comment
FWIW, this sounds like the exact same issue I was having (in IE 6 only 
though) that lead me to re-compress prototype.js 
(http://lists.horde.org/archives/cvs/Week-of-Mon-20080218/075089.html).



I'm seeing it again now in IE 6 and IE 7 although in IE 7 it's only 
when doing "ajax-y" thinks like the original post below.  in IE 6 it 
happens during ajax-y things as well as when navigating from one time 
span to another..both with the "style is not an object error."



Using the uncompressed version of prototype still yields the error - 
it's line 2253 of prototype.js
2008-04-11 12:40:41 jochem (at) mondrian (dot) nl Comment #4 Reply to this comment
I just updated horde with cvs update -PdC in the horde/ directory 
(confirmed that kronolith also got updated), I've done that again this 
morning before testing with the src scripts and yet again cleared 
cache, and I still see the same behavior.



This is the error I get now:

Line: 2253

Char: 5

Error: 'style' is null or not an object'

code: 0

URL: https://domain.tld/horde/kronolith/
2008-04-10 15:27:42 Chuck Hagenbuch Comment #3
State ⇒ Feedback
Reply to this comment
Are you using latest CVS of both Horde and Kronolith, and have you 
cleared your browser caches? I think I fixed something similar to this 
a few weeks ago or more.



If not, you can use the .js files in js/src/ (just copy them over the 
js/ files) to get a better line number and error message.
2008-04-10 10:59:04 jochem (at) mondrian (dot) nl Comment #2 Reply to this comment
This also occurs when trying to go to the next or previous month, so 
I'm assuming it's any AJAX-y action that's causing this problem.



A colleague of mine just reported that she's had this problem all 
week, while I just updated to the latest version of horde this morning 
(the previous update round being a couple of months ago), so I also 
assume this is a bug introduced by a Microsoft update.



If a fix to this problem is going to take a while, is there a way to 
turn off the AJAX in kronolith?
2008-04-10 10:17:56 jochem (at) mondrian (dot) nl Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 3. High
Summary ⇒ Blank page when selecting alternative calendar
Queue ⇒ Kronolith
Milestone ⇒
Patch ⇒ No
Reply to this comment
When I try to check a second calendar (or uncheck the first one) in 
the little side box in kronolith, while using IE7, I get a completely 
white screen (the right frame when having the sidebar enabled), with 
an "error on page":

Line 2

Char 38133

Error 'style' is null or not an object

I think I've tracked it down to kronolith/js/prototype.js, but as this 
file is apparently run through a mangler / optimizer, I can't fix it 
myself.



Seamonkey and Firefox seem to have no problems.

Saved Queries