6.0.0-git
2021-01-18

[#2401] force-cgi-redirect problem
Summary force-cgi-redirect problem
Queue Horde Base
Queue Version 3.0.5
Type Bug
State Resolved
Priority 2. Medium
Owners
Requester zoli (at) polarhome (dot) com
Created 2005-08-06 (5644 days ago)
Due
Updated 2005-08-08 (5642 days ago)
Assigned 2005-08-07 (5643 days ago)
Resolved 2005-08-08 (5642 days ago)
Milestone
Patch No

History
2005-08-08 16:45:15 Chuck Hagenbuch Comment #4
State ⇒ Resolved
Reply to this comment
Fixed in HEAD and 3.0.6. You can use this patch in the interim:

http://cvs.horde.org/diff.php/framework/Horde/Horde.php?r1=1.489.2.24&r2=1.489.2.25&ty=u
2005-08-07 06:36:11 zoli (at) polarhome (dot) com Comment #3 Reply to this comment
hi,



in the repport you can find two apache log lines. The exact URLs

With words I would decribe as follows:



First log record:

IMP list INBOX contents last page. Error occures when I press button < 
in order to list previous or first page.



(I get same error when I try to delete a mail)



Second log:

Try to add new entry into kronolith. Error occurs when you press the 
save button.



Circumstanes:

Horde: 3.0.5

Imp: H3 (4.0.3)

Ingo: H3 (1.0.1)

Kronolith: H3 (2.0.3)

Mnemo: H3 (2.0.1)

Nag: H3 (2.0.2)

Turba: H3 (2.0.3)



IMP is used for authentication agains an IMAPS host.

Actually you may check config at 
http://www.polarhome.com/horde/test1.php (with horde 3.0.4)
2005-08-07 01:40:31 Chuck Hagenbuch Version ⇒ 3.0.5
 
2005-08-07 01:40:10 Chuck Hagenbuch Comment #2
State ⇒ Feedback
Priority ⇒ 2. Medium
Reply to this comment
Does the /cgi-bin/php path show up in either SCRIPT_NAME, PHP_SELF, or 
REQUEST_URI? Where *exactly* are the urls containing it generated?
2005-08-06 23:19:02 zoli (at) polarhome (dot) com Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 3. High
Summary ⇒ force-cgi-redirect problem
Queue ⇒ Horde Base
Reply to this comment
hi,



this problem I find in 3.0.5 final (you haven't had that choice 
therfore I choose the most close)



When php is compiled with --enable-force-cgi-redirect (and I guess all 
production sites that run php in CGI mode are build with this option)

some calls fail.

This happen, because force-cgi-redirect  option will not allow PHP to 
be invoked directly as /cgi-bin/php... but this is exatly what horde 
3.0.5 final does:



kitty.polarhome.com - - [07/Aug/2005:00:58:04 +0200] "GET 
/cgi-bin/php?nocache=3oluydwjq268&page=1 HTTP/1.1" 400 643 
"http://www.polarhome.com/horde/imp/mailbox.php?mailbox=INBOX
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 
1.1.4322)"



kitty.polarhome.com - - [07/Aug/2005:01:00:49 +0200] "GET 
/cgi-bin/php?uq=2a2cc96afac9b0be4d7f27562f6d9d02 HTTP/1.1" 400 643 
"http://www.polarhome.com/horde/kronolith/delevent.php?eventID=9f839bee81a9035298b8b8b9e8a988e1&calendar=zoli%40redhat.polarhome.com&timestamp=1122782400&url=%2Fcgi-bin%2Fphp" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 
1.1.4322)"



Earlier releases did not have this behaviour.



Can this be solved with some configuration option, or this is a bug?



Thank you very much.regards,

Z






Saved Queries