6.0.0-git
2018-12-15

[#14829] do not use outdated S/MIME certificates
Summary do not use outdated S/MIME certificates
Queue IMP
Queue Version 6.2.21
Type Bug
State Unconfirmed
Priority 2. Medium
Owners
Requester lauffer (at) ph-freiburg (dot) de
Created 2018-06-26 (172 days ago)
Due
Updated 2018-06-26 (172 days ago)
Assigned
Resolved
Milestone
Patch No

History
2018-06-26 07:52:31 lauffer (at) ph-freiburg (dot) de Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 2. Medium
Summary ⇒ do not use outdated S/MIME certificates
Queue ⇒ IMP
Milestone ⇒
Patch ⇒ No
Reply to this comment
If you encrypt a message IMP does not check if the already stored 
certificate is outdated.

I would recommend that we warn and or not use this cert. And/or maybe 
add a login job to check stored certificates and remove the outdated 
ones...?

A further improvement would be tho check the CRL... hm...

What do you think?

Saved Queries