6.0.0-git
2020-04-08

[#14309] php-mongodb support
Summary php-mongodb support
Queue Horde Framework Packages
Type Enhancement
State Accepted
Priority 1. Low
Owners
Requester nish.aravamudan (at) canonical (dot) com
Created 2016-03-30 (1470 days ago)
Due
Updated 2019-12-20 (110 days ago)
Assigned
Resolved
Milestone
Patch No

History
2019-12-20 10:28:07 build+horde (at) de-korte (dot) org Comment #5 Reply to this comment
How popular is MongoDB after the SSPL license went into effect Oct 18th, 2018?
2019-12-20 05:11:01 matt (at) bitech (dot) biz Comment #4 Reply to this comment
This unfinished migration seems to be the root cause of why the 
package repos for rpm based systems have unresolvable conflicts when 
trying to upgrade PHP beyond 5.6 when horde is installed.
2016-04-19 15:20:05 nish (dot) aravamudan (at) canonical (dot) com Comment #3 Reply to this comment
Just to be clear, and for documentation purposes, the compatibility 
necessary is probably with: 
https://github.com/mongodb/mongo-php-library rather than the MongoDB 
extension itself, and the dependency should be expressed as such.
2016-03-31 10:53:17 Jan Schneider Comment #2
Summary ⇒ php-mongodb support
Reply to this comment
Planned yes, but no work has been done into this direction yet.
2016-03-31 10:52:43 Jan Schneider Type ⇒ Enhancement
State ⇒ Accepted
Priority ⇒ 1. Low
 
2016-03-30 21:55:49 nish (dot) aravamudan (at) canonical (dot) com Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 1. Low
Summary ⇒ php-mongodb support?
Queue ⇒ Horde Framework Packages
Milestone ⇒
Patch ⇒ No
Reply to this comment
php-mongo is deprecated 
(http://php.net/manual/en/mongo.installation.php) and doesn't seem to 
support PHP7. php-mongodb does not provide a MongoClient interface. Is 
there any plan to update php-horde-mongo to be compliant with the 
newer APIs?

Saved Queries