6.0.0-git
2019-12-06

[#14077] language problem in menu-bar after successful login
Summary language problem in menu-bar after successful login
Queue Horde Base
Queue Version 5.2.6
Type Bug
State Not A Bug
Priority 1. Low
Owners
Requester kkonnov (at) parallels (dot) com
Created 2015-08-04 (1585 days ago)
Due
Updated 2019-03-27 (254 days ago)
Assigned 2015-08-05 (1584 days ago)
Resolved 2015-08-08 (1581 days ago)
Milestone
Patch No

History
2019-03-27 11:18:22 contact (at) mgert (dot) tn Comment #13 Reply to this comment
j'arrive pas a changer la langue de l'anglais au fran├žais
2015-08-08 15:01:35 Michael Rubinsky Comment #12
State ⇒ Not A Bug
Reply to this comment
I just updated the demo site to the most recent pear version
(5.2.10), logged in using German and the menu appears correctly
translated in German.
Hello,
What about Espanol? On your demo server it's not translated at all. 
All menus in English. Please advice.
The demo server did not have all the locales installed. I have fixed 
this, and should now work for Espanol, or any other language.

Closing, since this is not a bug, but misconfiguration of the server 
(not having the desired locales installed).

2015-08-07 05:19:46 kkonnov (at) parallels (dot) com Comment #11 Reply to this comment
I just updated the demo site to the most recent pear version 
(5.2.10), logged in using German and the menu appears correctly 
translated in German.
Hello,
What about Espanol? On your demo server it's not translated at all. 
All menus in English. Please advice.
2015-08-06 15:45:21 Michael Rubinsky Comment #10 Reply to this comment
Cannot reproduce with our current PEAR releases.
Hello Michael.
Thank you for your reply.
Can you provide me with the link to your current release.
http://pear.horde.org/

All of our software is installed via PEAR. For more information read 
the INSTALL document:

http://www.horde.org/apps/webmail/docs/INSTALL
2015-08-06 15:43:20 Michael Rubinsky Comment #9 Reply to this comment
I just updated the demo site to the most recent pear version (5.2.10), 
logged in using German and the menu appears correctly translated in 
German.
2015-08-06 14:34:21 kai (dot) spindler (at) nethinks (dot) com Comment #8 Reply to this comment
What happens if you set your desired language in the preferences directly?
It is the same, I need to click on a topmenu item to see the menu in 
the preferred language.
2015-08-06 14:20:41 Michael Rubinsky Comment #7 Reply to this comment
What happens if you set your desired language in the preferences directly?
2015-08-06 11:51:19 kai (dot) spindler (at) nethinks (dot) com Comment #6 Reply to this comment
But the menue is only in English directly after the login. When using 
German for example the menu becomes German after clicking on "webmail" 
once.
2015-08-06 11:45:54 almikhailov (at) parallels (dot) com Comment #5 Reply to this comment
Another bug about localization in other places:
https://bugs.horde.org/ticket/14079
Horde localization isn't completed
2015-08-06 11:01:35 almikhailov (at) parallels (dot) com Comment #4 Reply to this comment
Looks like, Horde uses different sources for locales determination in 
different places. In menu it uses information from headers, but in 
other places from login window. This is root cause of this bug. User 
cannot change language for menu in login window.
2015-08-06 04:22:54 kkonnov (at) parallels (dot) com Comment #3 Reply to this comment
Cannot reproduce with our current PEAR releases.
Hello Michael.
Thank you for your reply.
Can you provide me with the link to your current release.
Also, I have performed the same steps on your demo server and the 
issue persists:

*steps to reproduce*

1 Got to http://demo.horde.org/login.php
2 choose language - Espanol
3 login under demo account
all menus still in english.

Please advice how to make it spanish.

2015-08-05 15:43:13 Michael Rubinsky Comment #2
State ⇒ Feedback
Priority ⇒ 1. Low
Reply to this comment
Cannot reproduce with our current PEAR releases.
2015-08-04 13:13:12 kkonnov (at) parallels (dot) com Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 2. Medium
Summary ⇒ language problem in menu-bar after successful login
Queue ⇒ Horde Base
Milestone ⇒
Patch ⇒ No
Reply to this comment
===PRODUCT/VERSION, OS/ARCHITECTURE===
OS version, architecture: CentOS 6, 64bit
Horde: psa-horde-5.2.6-cos6.build1200150722.16.noarch
== PROBLEM DESCRIPTION ==
After updating horde to v5.2.6 language switching not working

== STEPS TO REPRODUCE ==
1. Make sure horde package is psa-horde-5.2.6-cos6.build1200150722.16.noarch
3. Try to login with horde different language other than English.

===ACTUAL RESULT===
- All the upper menu is in English and the settings are showing in 
English instead of other language (for example Espaniol).

===EXPECTED RESULT===
- All the settings and menu should be in the new language selected in Horde

=== EXPECTATIONS===
Please confirm this case bug and provide workaround for this case

- Working fine in psa-horde-5.2.1 and not working in psa-horde-5.2.6

Saved Queries