6.0.0-git
2019-05-19

[#10522] Incomplete send mail
Summary Incomplete send mail
Queue IMP
Queue Version 5.0.11
Type Bug
State Duplicate
Priority 2. Medium
Owners
Requester adominguez (at) cne (dot) gob (dot) ve
Created 2011-09-15 (2803 days ago)
Due
Updated 2011-09-15 (2803 days ago)
Assigned
Resolved 2011-09-15 (2803 days ago)
Milestone
Patch No

History
2011-09-15 17:39:24 Michael Slusarz Comment #2
State ⇒ Duplicate
Reply to this comment
Duplicate of Ticket #10122.  This should have been caught by the PEAR 
installer.
2011-09-15 17:34:27 adominguez (at) cne (dot) gob (dot) ve Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 2. Medium
Summary ⇒ Incomplete send mail
Queue ⇒ IMP
Milestone ⇒
Patch ⇒ No
Reply to this comment
Hi, I got a tricky error when I try to send a specific format mail, 
i.e. if you try to send the next email:

================================
Nothing after this line will be write because have an ó and end whit "." .

Not matter what I put now, nothing of it will be appear on the 
receiver mail, but will be appear on the sender's 'Sent' Folder.

Ads
asd
asd
asd
================================

The mail reader only will see the first line of it (Nothing after this 
line will be write because have an ó and end whit "." .)  and 
everything beyond that will be 'deleted'.  Thats only happened with 
IMP on Horde version 4, I already test it on H3 and work well.

Now I'll going to the freaky think of the error, first at all, the 
line have to have 74 character, one of then have to be a 
quoted-printable (non-ascii character) and the last one have to be '.' 
(the dot character). If the line include more that one "non-ascii 
character" you have to take out 2 character for each extra "non-ascii 
character".

Is not mandatory that it line have to be the first one, but if not, 
the previous world have to be a long one, for example:

================================
sds
sdadsasdasd asd asd asd asd asd asdadasd  asd asd asd
asd
oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo
Nothing after this line will be write because have an ó and end whit "." .

Not matter what I put now, nothing of it will be appear on the 
receiver mail, but will be appear on the sender's 'Sent' Folder.

Ads
asd
asd
asd
================================


But the line have to satisfied the previous condition.  Finally, the 
mail is ALWAYS stored correctly on the sender send directory.

Saved Queries