6.0.0-git
2019-03-20

[#1087] PGP Passphrase not accepted
Summary PGP Passphrase not accepted
Queue IMP
Queue Version 4.0.1
Type Bug
State Not A Bug
Priority 2. Medium
Owners
Requester nur.fuer.spam (at) gmx (dot) de
Created 2005-01-05 (5187 days ago)
Due
Updated 2005-01-21 (5171 days ago)
Assigned 2005-01-06 (5186 days ago)
Resolved 2005-01-21 (5171 days ago)
Milestone
Patch No

History
2005-01-21 10:55:34 Jan Schneider Comment #9
State ⇒ Not A Bug
Reply to this comment
You could try. My guess is, that it doesn't accept the ElGamal key, 
because these keys have been deprecated.



Closing, because this is not an IMP issue.
2005-01-15 16:39:02 nur (dot) fuer (dot) spam (at) gmx (dot) de Comment #8 Reply to this comment
After installing GnuPG from backports.org 
(http://backports.org/package.php?search=gnupg) it still doesn't work. 
I thought it could be an old-version-issue :), now its 
1.2.5-2.backports.org.1 instead if 1.0.x.

Do you think it could help to compile and install GnuPG from current sources?
2005-01-15 16:34:39 nur (dot) fuer (dot) spam (at) gmx (dot) de Comment #7 Reply to this comment
I think I could figure out the problem. That's what print_r($result) 
after  $result = $this->_callGpg($cmdline, 'w', $params['passphrase'], 
true, true) says:



( [output] => [stderr] => gpg: protection algorithm 254 is not 
supported gpg: encrypted with 2048-bit ELG-E key, ID xxxxxx, created 
2004-12-21 "xxxx" gpg: public key decryption failed: unknown cipher 
algorithm gpg: decryption failed: secret key not available gpg: [don't 
know]: invalid packet (ctb=09) [stdout] => )



I think I will find somethin in that direction. Any ideas?
2005-01-15 16:04:30 Jan Schneider Comment #6 Reply to this comment
That wouldn't help because you need to debug it on the server side. 
Take a look at the "verifyPassphrase" method in 
lib/Horde/Crypt/pgp.php and try to find out if the correct  passphrase 
reaches this point and what the $result variables actually contain.
2005-01-15 01:36:24 nur (dot) fuer (dot) spam (at) gmx (dot) de Comment #5 Reply to this comment
Yes, so it is. There are two entries displayed correctly. The only 
thing is that it doesn't accept my passphrase. If you would like i 
could create a test account for you so you could test it yourself.
2005-01-15 01:20:12 Jan Schneider Comment #4 Reply to this comment
A dumb question, because someone else happened this recently: are you 
sure that your private key has correctly been exported? The should be 
two entries for your personal key on the PGP page, one for the public, 
one for the private key.
2005-01-06 08:05:12 nur (dot) fuer (dot) spam (at) gmx (dot) de Comment #3 Reply to this comment
Ok, I tried a passphrase with and another one without special keys 
because this was my first idea. The key is an external one that was 
generated with Enigmail/GnuPT for Windows. Is there any possibility to 
have a debug log while entering the passphrase?

System is Debian Woody with PHP 4:4.3.10-1.dotdeb.0 from Dotdeb.org 
(Backport) and MySQL 4.0.23-0.dotdeb.0; Apache-SSL 
1.3.26.1+1.48-0woody3 with mod-php.
2005-01-06 00:07:35 Jan Schneider Comment #2
State ⇒ Feedback
Reply to this comment
This broad statement is plain wrong. Of course it accepts the correct 
passphrase. It does for everyone else. You need to provide more 
information to make this a useful bug report. Do you have some special 
characters in your passphrase, did you try other keys, other 
passphrases, did you try external keys vs. imp-generated ones, etc.
2005-01-05 22:38:05 nur (dot) fuer (dot) spam (at) gmx (dot) de Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 2. Medium
Summary ⇒ PGP Passphrase not accepted
Queue ⇒ IMP
Reply to this comment
IMP does not accept the correct passphrase and tells you that the 
passphrase is invalid.

Saved Queries