6.0.0-git
2019-03-18

[#5849] Language selection widget missing
Summary Language selection widget missing
Queue MIMP
Queue Version 1.0
Type Enhancement
State Resolved
Priority 2. Medium
Owners slusarz (at) horde (dot) org
Requester selsky (at) columbia (dot) edu
Created 2007-11-01 (4155 days ago)
Due
Updated 2007-12-22 (4104 days ago)
Assigned
Resolved 2007-12-22 (4104 days ago)
Milestone
Patch No

History
2007-12-22 07:13:43 Michael Slusarz Comment #5
Assigned to Michael Slusarz
State ⇒ Resolved
Reply to this comment
Fixed in IMP 4.2.
2007-12-06 15:20:46 Jan Schneider Comment #4 Reply to this comment
The Horde_Mobile code is calling htmlencode() an extra time.
Horde_Mobile_select needs an extra 'htmlchars' parameter like we use 
one for the Horde_Form language selection widgets through 
Horde_Form_enum.
2007-12-06 06:50:01 Matt Selsky Comment #3 Reply to this comment
imp/templates/login/mobile.inc has



if (!empty($lang_select)) {

//    $f->add($lang_select);

}



I uncommented it, and I now see a language widget.  The problem is 
that the HTML encodings for the foreign languages are now shown as 
encodings, aka ا instead of the foreign script.



The Horde_Mobile code is calling htmlencode() an extra time.
2007-11-06 21:55:45 Jan Schneider Comment #2
Type ⇒ Enhancement
State ⇒ Accepted
Priority ⇒ 2. Medium
Reply to this comment
That's not a bug, the language selection simply has never been added 
to the mobile login screen.
2007-11-01 17:38:10 Matt Selsky Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 1. Low
Summary ⇒ Language selection widget missing
Queue ⇒ MIMP
Reply to this comment
MIMP 1.0.2



The language selection widget is missing on the login page, even 
though the preferences for language are not locked.

Saved Queries