6.0.0-git
2019-03-18

[#5593] vtimezone relies on PHP timestamp date range
Summary vtimezone relies on PHP timestamp date range
Queue Horde Framework Packages
Queue Version FRAMEWORK_3
Type Bug
State Resolved
Priority 2. Medium
Owners
Requester robin.west (at) dal (dot) ca
Created 2007-08-01 (4247 days ago)
Due
Updated 2007-08-26 (4222 days ago)
Assigned 2007-08-01 (4247 days ago)
Resolved 2007-08-26 (4222 days ago)
Milestone
Patch No

History
2007-08-26 00:54:52 Chuck Hagenbuch Comment #4
State ⇒ Resolved
Reply to this comment
Given the lack of response saying that this *must* be handled, I'm 
closing this as having an acceptable resolution (either using PHP 5 or 
hacking in the adodb_time stuff oneself).
2007-08-01 20:17:06 Chuck Hagenbuch Comment #3
Summary ⇒ vtimezone relies on PHP timestamp date range
Reply to this comment
For the original reporter: fwiw, this would just work if you used PHP 5.
2007-08-01 20:16:25 Chuck Hagenbuch Comment #2
State ⇒ Feedback
Reply to this comment
This is a 32-bit timestamp issue. A quick but ugly fix would be to 
include the necessary functions from 
http://phplens.com/phpeverywhere/adodb_date_library right in 
vtimezone.php. Seems nasty but since a lot of timezone rules probably 
have years before 1970... thoughts?
2007-08-01 19:45:48 robin (dot) west (at) dal (dot) ca Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 2. Medium
Summary ⇒ problem displaying ical message in IMP
Queue ⇒ Horde Framework Packages
New Attachment: ical_message.txt Download
Reply to this comment
Hi - using Horde 3.1.4, IMP 4.1.4, PHP4.3.2.



I received a message in ical format (text/calendar) and when I view it 
in IMP I get a bunch of PHP errors at the top of the page:



Notice: Undefined offset: 1 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 2 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 1 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 2 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 1 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 2 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 1 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140

Notice: Undefined offset: 2 in 
/appl/webmail/horde/lib/Horde/iCalendar/vtimezone.php on line 140



Aside from that the message appears to display properly. Is there 
something I need to set in the Horde config in order to fix this? I 
have attached the complete message (names and email addresses removed) 
... not sure if you need to see the whole thing or just the iCal part, 
but there it is.

Saved Queries