6.0.0-git
2019-03-24

[#545] WWW on port 443
Summary WWW on port 443
Queue Nic
Type Enhancement
State Resolved
Priority 1. Low
Owners
Requester thomas (at) creativebusinessystems (dot) com
Created 2004-09-04 (5314 days ago)
Due
Updated 2005-06-14 (5031 days ago)
Assigned 2004-09-04 (5314 days ago)
Resolved 2005-06-14 (5031 days ago)
Milestone
Patch No

History
2005-06-14 19:38:05 Matt Selsky Comment #10
State ⇒ Resolved
Reply to this comment
Committed.
2005-06-14 08:29:02 Jan Schneider Comment #9 Reply to this comment
Yup.
2005-06-14 01:33:38 Matt Selsky Comment #8
State ⇒ Feedback
New Attachment: www_secure.patch Download
Reply to this comment
I went the extend Nic_Device_www route.  Looks OK?
2005-04-08 22:19:45 Chuck Hagenbuch Comment #7 Reply to this comment
How about making ssl a config setting (or just having a www_secure 
driver that extends the www driver, so people just choose the right 
one)?
2005-04-08 22:09:30 selsky (at) columbia (dot) edu Comment #6
New Attachment: nic.patch Download
Reply to this comment
Does a simple check for port 443 (and then use SSL) do the right thing(tm)?
2005-02-20 21:44:24 Jan Schneider Comment #5
State ⇒ Accepted
Reply to this comment
2004-09-04 16:50:40 Jan Schneider Comment #4 Reply to this comment
Yes.
2004-09-04 16:03:27 thomas (at) creativebusinessystems (dot) com Comment #3 Reply to this comment
The services applet seems to identify SSL services correctly. Is this 
a separate and distinct function from the Status Monitor?
2004-09-04 10:13:23 Jan Schneider Comment #2
Type ⇒ Enhancement
State ⇒ Assigned
Priority ⇒ 1. Low
Reply to this comment
This is no bug, Nic simply doesn't support SSL connects yet.
2004-09-04 01:53:56 thomas (at) creativebusinessystems (dot) com Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 2. Medium
Summary ⇒ WWW on port 443
Queue ⇒ Nic
Reply to this comment
Setting the following in devices.php

$devices['www2']['driver'] = 'www';

$devices['www2']['params'] = array();

$devices['www2']['params']['hostspec'] = 'www.creativebusinessystems.com';

$devices['www2']['params']['port'] = '443';

$devices['www2']['params']['hostname'] = 'slapshot';

$devices['www2']['params']['subsystem'] = 'WWW';

Causes:

Host: www.creativebusinessystems.com

Connection Failed

I tried setting $devices['www2']['params']['subsystem'] = 'HTTPS';

as well with the same result.

Saved Queries