6.0.0-git
2019-03-19

[#2938] Image attachment missed
Summary Image attachment missed
Queue IMP
Queue Version HEAD
Type Bug
State Not A Bug
Priority 2. Medium
Owners slusarz (at) horde (dot) org
Requester chuck (at) horde (dot) org
Created 2005-11-08 (4879 days ago)
Due
Updated 2005-11-13 (4874 days ago)
Assigned 2005-11-08 (4879 days ago)
Resolved 2005-11-13 (4874 days ago)
Milestone
Patch No

History
2005-11-13 20:22:00 Michael Slusarz Comment #3
State ⇒ Not A Bug
Reply to this comment
Looking at the structure of the message, by the letter of the RFC 
(2387) it appears that we actually *are* displaying it correctly.



This message is structured as follows:



multipart/related

   multipart/alternative

     text/plain

     text/html

   image/jpeg

   image/jpeg

   ...



What's important is that the image files are under the 
multipart/related.  From that RFC, it states that MUA's that can not 
handle multipart/related will display this message as multipart/mixed. 
  However,

   "User Agents that understand Multipart/Related shall ignore the 
disposition type within a Multipart/Related body part."

   "for a Multipart/Related object, proper display cannot be achieved by

    individually displaying the constituent body parts"



If the 'root' object of the multipart/related object does not 
reference the other data objects in that part, they do *not* 
necessarily need to be displayed to the user and can be ignored.



But obviously it would be nice to have a way to display all MIME parts 
available in a message.  However, this means that this bug is simply 
another duplicate of Bugs 1863 and Bugs 1866.
2005-11-08 21:33:50 Chuck Hagenbuch Comment #2
New Attachment: Hard Zend Workers in Frankfurt.eml Download
Reply to this comment
... and the file, since I haven't fixed this damn bug in Whups yet.
2005-11-08 21:33:11 Chuck Hagenbuch Comment #1
Type ⇒ Bug
State ⇒ Assigned
Priority ⇒ 2. Medium
Summary ⇒ Image attachment missed
Queue ⇒ IMP
Assigned to Michael Slusarz
Reply to this comment
Viewing the attached email in IMP, I don't have an option anywhere to 
view or download the image attachment, though it appears to be a valid 
message (generated by Outlook though it is).

Saved Queries