6.0.0-git
2019-03-21

[#2918] Unwanted PHP warnings and notices when using the latest stable version of PHP
Summary Unwanted PHP warnings and notices when using the latest stable version of PHP
Queue IMP
Queue Version 4.0.4
Type Bug
State Not A Bug
Priority 1. Low
Owners
Requester virg2 (at) xiode (dot) com
Created 2005-11-04 (4885 days ago)
Due
Updated 2005-11-07 (4882 days ago)
Assigned 2005-11-06 (4883 days ago)
Resolved 2005-11-07 (4882 days ago)
Milestone
Patch No

History
2005-11-07 09:39:58 Jan Schneider Comment #4
State ⇒ Not A Bug
Reply to this comment
Warning: fread(): Length parameter must be greater than 0. in
/home/httpd/vhosts/webmail/imp/lib/Compose.php on line 671
IMP can't read files in your temporary directory.
Notice: Only variables should be assigned by reference in
/home/httpd/vhosts/webmail/imp/lib/Compose.php on line 129
Downgrade PHP, upgrade the Mail PEAR package, or configure PHP to not 
show notices.
2005-11-07 09:26:17 Jan Schneider Version ⇒ 4.0.4
 
2005-11-07 07:12:01 virg2 (at) xiode (dot) com Comment #3 Reply to this comment
Thanks for following up. I'm not using the HEAD version. Here's 
information from the Horde test page :



Horde Version

Horde: 3.0.5



Horde Applications

Gollem: 1.0-cvs (run Gollem tests)

Horde: 3.0.5

Imp: H3 (4.0.4) (run Imp tests)

Ingo: H3 (1.0.2) (run Ingo tests)

Jonah: 0.0.2 (run Jonah tests)

Kronolith: H3 (2.0.3)

Nag: H3 (2.0.1)

Sam: 0.1-cvs

Turba: H3 (2.0.2) (run Turba tests)

Whups: 1.0-cvs



PHP Version

View phpinfo() screen

View loaded extensions

PHP Version: 4.4.0

PHP Major Version: 4.4

PHP Minor Version: 0

PHP Version Classification: release

You are running a supported version of PHP.
2005-11-06 10:44:24 Jan Schneider Comment #2
State ⇒ Feedback
Reply to this comment
These lines don't exist in HEAD such that they could cause these error 
messages. Please specify the correct version.
2005-11-04 18:49:49 virg2 (at) xiode (dot) com Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 1. Low
Summary ⇒ Unwanted PHP warnings and notices when using the latest stable version of PHP
Queue ⇒ IMP
Reply to this comment
There are unwanted PHP warnings and notices when using the latest 
stable version of PHP.



For example, after a user composes a message and submits then this 
warning and notice show up in the following page :



Warning: fread(): Length parameter must be greater than 0. in 
/home/httpd/vhosts/webmail/imp/lib/Compose.php on line 671



Notice: Only variables should be assigned by reference in 
/home/httpd/vhosts/webmail/imp/lib/Compose.php on line 129

Saved Queries