6.0.0-git
2019-04-23

[#1320] _horde_hook_postauthenticate does not work correctly when IMP is used for authentication
Summary _horde_hook_postauthenticate does not work correctly when IMP is used for authentication
Queue Horde Base
Queue Version 3.0.2
Type Bug
State Resolved
Priority 3. High
Owners Horde Developers (at)
Requester luc.germain (at) usherbrooke (dot) ca
Created 2005-02-07 (5188 days ago)
Due
Updated 2005-02-09 (5186 days ago)
Assigned 2005-02-08 (5187 days ago)
Resolved 2005-02-09 (5186 days ago)
Milestone
Patch No

History
2005-02-09 00:46:54 Jan Schneider Comment #2
State ⇒ Resolved
Reply to this comment
Fixed in CVS and 3.0.3.
2005-02-08 08:44:56 Jan Schneider State ⇒ Assigned
Assigned to Horde DevelopersHorde Developers
 
2005-02-07 17:19:15 luc (dot) germain (at) usherbrooke (dot) ca Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 3. High
Summary ⇒ _horde_hook_postauthenticate does not work correctly when IMP is used for authentication
Queue ⇒ Horde Base
Reply to this comment
On Horde 3.0.2, I defined the hook function 
_horde_hook_postauthenticate to limit the users who have access to 
horde, and activated it's use in the horde configuration. The 
authentication is done by IMP through  IMAP, and the hook  is used to 
further restrict access to a list of users.



For users not in the list, the login page does indeed show that the 
login failed, but the menu in the left  frame still appear complete as 
if the user was authenticated, and the user can access to all others 
apps except his mailbox through the menu. I think this function should 
block access to all applications.

Saved Queries