6.0.0-git
2019-03-23

[#11824] Upgrade breaks webmail gui
Summary Upgrade breaks webmail gui
Queue Horde Groupware Webmail Edition
Queue Version 5.0.2
Type Bug
State Duplicate
Priority 1. Low
Owners
Requester steven (at) swartsit (dot) com
Created 2012-12-06 (2298 days ago)
Due
Updated 2012-12-07 (2297 days ago)
Assigned
Resolved 2012-12-07 (2297 days ago)
Milestone
Patch No

History
2012-12-07 01:52:16 steven (at) swartsit (dot) com Comment #6 Reply to this comment
Thanks Michael,
Very prompt and efficient.
Also I realize now that Horde is not the issue, and yet you provided a 
workaround.
Top stuff,
Regards,
Steve
2012-12-07 01:49:11 Michael Slusarz Comment #5
State ⇒ Duplicate
Reply to this comment
Duplicate of #11820.
2012-12-07 01:29:17 steven (at) swartsit (dot) com Comment #4 Reply to this comment
Duplicate of my own ticket ? Seems strange.

Also I am running the latest PHP for the Debian standard apt source.

PHP 5.3.3-7+squeeze14 with Suhosin-Patch (cli) (built: Aug  6 2012 14:18:06)

Either way, an update from Pear last night broke the installation, by 
the looks of it many installations, but now has been fixed.

So cheers
2012-12-06 21:23:47 Michael Slusarz Comment #3 Reply to this comment
Should be set to HIGH priority!!!
Duplicate of #11824.  Most definitely not a high priority because you 
are using an outdated version of PHP.
2012-12-06 17:59:21 steven (at) swartsit (dot) com Comment #2 Reply to this comment
Should be set to HIGH priority!!!
2012-12-06 17:58:47 steven (at) swartsit (dot) com Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 1. Low
Summary ⇒ Upgrade breaks webmail gui
Queue ⇒ Horde Groupware Webmail Edition
Milestone ⇒
Patch ⇒ No
Reply to this comment
Just did a pear upgrade -a -B -c horde tonight and now I can't log 
into my webmail.

This is what Firebug debugs it as:

#####################################

"NetworkError: 500 Internal Server Error - 
https://www.swartsit.com/horde/login.php"

login.php

The character encoding of the HTML document was not declared. The 
document will render with garbled text in some browser configurations 
if the document contains characters from outside the US-ASCII range. 
The character encoding of the page must be declared in the document or 
in the transfer protocol.

###################

Have tried in both IE10 and Firefox 17.0.1
Have cleared the cache on both

Restarted Apache as well, just to be sure.

This is what the apache log gives:

##########################

[Fri Dec 07 01:57:15 2012] [error] [client 1X4.XX9.1X7.7] PHP Fatal 
error:  Can't inherit abstract function Iterator::next() (previously 
declared abstract in Horde_Imap_Client_Tokenize) in 
/usr/share/php/Horde/Imap/Client/Tokenize.php on line 29, referer: 
https://www.example.com/horde/login.php

##########################

Regards,
Steven Swarts

Saved Queries