6.0.0-git
2019-04-23

[#10713] Some events do not get synchronised using ActiveSync
Summary Some events do not get synchronised using ActiveSync
Queue Kronolith
Queue Version 3.0.11
Type Bug
State Not A Bug
Priority 1. Low
Owners mrubinsk (at) horde (dot) org
Requester steffo76 (at) gmx (dot) de
Created 2011-11-04 (2727 days ago)
Due
Updated 2011-11-13 (2718 days ago)
Assigned 2011-11-04 (2727 days ago)
Resolved 2011-11-13 (2718 days ago)
Milestone
Patch No

History
2011-11-13 02:37:59 Michael Rubinsky Comment #8
State ⇒ Not A Bug
Reply to this comment
Cannot reproduce.
2011-11-08 19:59:41 steffo76 (at) gmx (dot) de Comment #7 Reply to this comment
I don't know why it stopped working, I even erased the whole calendar 
and added some events which didn't help. I guess there is some bug in 
the phones ActiveSync implementation so I'll buy a SyncML client.
2011-11-07 16:23:26 Michael Rubinsky Comment #6 Reply to this comment
The only thing I can see that is different with the one event in the 
log that you pointed out is that the description contains some 
non-ascii characters, while the other events in the log do not.

This shouldn't be an issue though, and is supported. I tested this 
locally, and the event was successfully sync'd.

You said that you have some events that do *not* show up in your 
synclog also? Are you sure they are in a calendar that you have 
selected to sync?  Check your horde log and server log for any errors 
as well.

I cannot reproduce any of this.

The next step would be to capture the communication over the wire with 
a tool like wireshark, though seeing what is in your log, I doubt this 
would be of help.
2011-11-04 22:39:59 steffo76 (at) gmx (dot) de Comment #5 Reply to this comment
That's strange, software on the phone didn't change. One example for 
an event that shows up in the log but not on the phone is 
20111016105038.anlzV75HGY9Omprel79CSqA@sync.peterpan.xyz

Other events do not show up, like an event on 2011/9/9 18:00.

I just created a test event which doesn't show up in the synclog either.
2011-11-04 22:26:54 Michael Rubinsky Comment #4 Reply to this comment
I don't see anything obviously wrong n a protocol level.  Do you see 
the data for the missing events in the log? If so, which entry?
2011-11-04 21:58:56 steffo76 (at) gmx (dot) de Comment #3
New Attachment: activesynclog Download
Reply to this comment
Hopefully this helps

2011-11-04 21:06:08 Michael Rubinsky Comment #2
Assigned to Michael Rubinsky
State ⇒ Feedback
Reply to this comment
At a minimum I will need a sync log that includes the attempt to sync 
one of the missing events.

See http://wiki.horde.org/ActiveSync for details.
2011-11-04 20:49:48 steffo76 (at) gmx (dot) de Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 1. Low
Summary ⇒ Some events do not get synchronised using ActiveSync
Queue ⇒ Kronolith
Milestone ⇒
Patch ⇒ No
Reply to this comment
I am using a Motorola defy which synchronises its contacts and 
calendar with horde. This used to work well but a while ago I noticed 
that some events are missing from the phones calendar- they just don't 
get synchronised. I tried everything from resetting the sync state in 
horde to removing and adding the account on the phone. I can't see a 
difference between the events that get synchronised and those that 
don't. I only have on calendar.

Saved Queries