6.0.0-git
2019-03-19

[#10022] Nokia N900 ActiveSync for calendar doesn't work
Summary Nokia N900 ActiveSync for calendar doesn't work
Queue Synchronization
Queue Version Git master
Type Bug
State Duplicate
Priority 1. Low
Owners
Requester yves.bilgeri (at) bbw (dot) ch
Created 2011-05-01 (2879 days ago)
Due
Updated 2011-05-16 (2864 days ago)
Assigned
Resolved 2011-05-03 (2877 days ago)
Milestone
Patch No

History
2011-05-16 14:59:36 yves (dot) bilgeri (at) bbw (dot) ch Comment #3 Reply to this comment
I can confirm that it now works with patch [0] applied from Bug: 9733

[0] 
http://git.horde.org/horde-git/-/commit/a65072badbcb509690ca009bb0770ca1c641e393
2011-05-03 22:04:26 Michael Rubinsky Comment #2
State ⇒ Duplicate
Reply to this comment
This looks like another symptom of Bug: 9733
2011-05-01 15:28:03 yves (dot) bilgeri (at) bbw (dot) ch New Attachment: networkdump.pcap Download
 
2011-05-01 15:26:29 yves (dot) bilgeri (at) bbw (dot) ch Comment #1
Type ⇒ Bug
State ⇒ Unconfirmed
Priority ⇒ 1. Low
Summary ⇒ Nokia N900 ActiveSync for calendar doesn't work
Queue ⇒ Synchronization
Milestone ⇒
Patch ⇒ No
New Attachment: activesync.log Download
Reply to this comment
If I configure a Nokia N900 [0] for calendar syncing the phone tries 
to sync and stops after a few seconds with status "Stopped". Address 
syncing works well on the phone (See resloved Bug #9757).

Attached is a network dump and the Horde activesync.log of a tried 
calendar sync.

Pleas tell me, if I can provide you more information to solve the 
problem. One thing I could do additionally, is to enable logging on 
the N900.

horde.log
2011-05-01T16:34:25+02:00 NOTICE: HORDE [imp] Login success for 
test.user@example.net (Horde user test.user@example.net
[194.230.155.22] to {localhost:143 [imap]} [pid 17555 on line 202 of 
"/var/www/horde4/imp/lib/Auth.php"]
2011-05-01T16:34:27+02:00 NOTICE: HORDE [imp] Login success for 
test.user@example.net (Horde user test.user@example.net
[194.230.155.22] to {localhost:143 [imap]} [pid 17555 on line 202 of 
"/var/www/horde4/imp/lib/Auth.php"]
2011-05-01T16:34:28+02:00 NOTICE: HORDE [imp] Login success for 
test.user@example.net (Horde user test.user@example.net
[194.230.155.22] to {localhost:143 [imap]} [pid 17555 on line 202 of 
"/var/www/horde4/imp/lib/Auth.php"]
2011-05-01T16:34:28+02:00 NOTICE: HORDE [turba] PHP ERROR: Undefined 
offset:  1 [pid 17555 on line 302 of 
"/var/www/horde4/pear/php/Net/DNS2.php"]

access.log
194.230.155.22 - test.user@example.net [01/May/2011:16:34:25 +0200] 
"POST 
/Microsoft-Server-ActiveSync?Cmd=FolderSync&DeviceId=356938031943765&DeviceType=SmartPhone HTTP/1.1" 200 166 "-" 
"N900/1.1"
194.230.155.22 - test.user@example.net [01/May/2011:16:34:27 +0200] 
"POST 
/Microsoft-Server-ActiveSync?Cmd=Sync&DeviceId=356938031943765&DeviceType=SmartPhone HTTP/1.1" 200 82 "-" 
"N900/1.1"

[0] http://wiki.maemo.org/Mail_For_Exchange_%28MfE%29_Heartbeat_and_FAQ

Saved Queries