[#9043] Xinha javascript alert in Horde
Summary Xinha javascript alert in Horde
Queue Horde Base
Queue Version 3.3.8
Type Bug
State Resolved
Priority 2. Medium
Owners jan@horde.org
Requester paul_j@inbox.lv
Created 2010-05-18 (3407 days ago)
Due 05/19/2010 (3406 days ago)
Updated 2010-05-25 (3400 days ago)
Assigned 2010-05-18 (3407 days ago)
Resolved 2010-05-25 (3400 days ago)
Milestone
Patch No

Comments
paul_j@inbox.lv 2010-05-18 19:13:20
Hello.

When trying to compose anew message in IE, I got the alert message:

Error loading Language-File (/services/editor/xinha/lang/lv.js)
Function Error () {native code}

In 2008 year this problem was raised but not resolved as it seems.
Any suggestions?

Jan Schneider <jan@horde.org> 2010-05-18 21:04:47
Which Horde version do you use? There is no such error string in Xinha 
shipped with any recent Horde version.

paul_j@inbox.lv 2010-05-19 06:45:12
> Which Horde version do you use? There is no such error string in 
> Xinha shipped with any recent Horde version.

I use 4.3.5. Will try to update to the latest version.

paul_j@inbox.lv 2010-05-19 19:48:25
Instaled Horde Groupware Webmail Edition 1.2.6, and the problem persists.

paul_j@inbox.lv 2010-05-19 19:50:05
Just to add- the alert comes out only in Internet Explorer

Jan Schneider <jan@horde.org> 2010-05-19 20:57:15
Well, like I said, this error string doesn't even exist in Xinha. You 
must have a messed up installation, or pointing your browser to an 
older version.

paul_j@inbox.lv 2010-05-25 16:55:03
Horde Groupware Webmail Edition 1.2.6

./horde-webmail-latest.tar
./services/editor/xinha/src/XinhaCore.js
./services/editor/xinha/XinhaCore.js

These files have the following line of code:

....Xinha._geturlcontent(url);if(_233!==""){try{eval("lang = 
"+_233)}catch(ex){alert("Error reading Language-File 
("+url+"):\n"+Error.toString());lang={}}}......

Jan Schneider <jan@horde.org> 2010-05-25 17:04:16
That doesn't match the original error message that you posted.

paul_j@inbox.lv 2010-05-25 17:15:54
> That doesn't match the original error message that you posted.

Yes. you are right. A big mistake of mine. Sorry.

In fact the error is:

Error reading Language-File (/services/editor/xinha/lang/lv.js)
function Error () { [native code] }

Waht is the reason for such error?

paul_j@inbox.lv 2010-05-25 17:52:08
The alert is gone after chnaging the .js file encoding to UTF-8.


CVS Commit <cvs@lists.horde.org> 2010-05-25 19:54:41

Jan Schneider <jan@horde.org> 2010-05-25 19:54:58
Thanks for the hint!