[#5358] $pref['mail_domain'] / $conf['maildomain'] not being appended to unqualified addresses
Summary $pref['mail_domain'] / $conf['maildomain'] not being appended to unqualified addresses
Queue IMP
Queue Version HEAD
Type Bug
State Resolved
Priority 2. Medium
Owners Horde Developers, slusarz@horde.org
Requester liamr@deathstar.org
Created 2007-05-15 (5274 days ago)
Due
Updated 2007-05-30 (5259 days ago)
Assigned 2007-05-26 (5263 days ago)
Resolved 2007-05-30 (5259 days ago)
Milestone IMP 4.2
Patch No

Comments
liamr@deathstar.org 2007-05-15 14:07:01
in 4.0.x, if you gave it an unqualified address, it would tack a 
default maildomain on to it.



IMP 4.2 CVS appears to have a preference for this purpose - 
$pref['mail_domain'], which is described as..



    When sending mail or expanding addresses, what domain should we

    append to unqualified addresses (email addresses without "@")?



There's also a field in config/servers.php that contains a default 
mail domain ( $conf['maildomain'] / $_SESSION['imp']['maildomain']), 
which is described as..



     This will also be used to complete unqualified addresses when 
composing mail.



Nothing appears to actually using these values.  Instead, if you try 
sending a message with an unqualified address, you get..



    There was an error sending your message: Validation failed for: joeuser@



Seems like the change would go in imp/lib/Imple/ContactAutoCompleter.php

Chuck Hagenbuch <chuck@horde.org> 2007-05-19 04:01:33
This should be fixed before IMP 4.2.

Michael Slusarz <slusarz@horde.org> 2007-05-26 22:58:12

liamr@deathstar.org 2007-05-30 15:40:12
It does seem to fix the issue, but it lacks the visual cue provided by 
previous versions, and I think users will notice that... which could 
be potentially confusion / generate complaints.



Earlier versions used javascript to tack the default domain onto the 
unqualified address on To/Cc/Bcc lines in the message composition 
screen.



Michael Slusarz <slusarz@horde.org> 2007-05-30 15:54:02
> It does seem to fix the issue, but it lacks the visual cue provided

> by previous versions, and I think users will notice that... which

> could be potentially confusion / generate complaints.

>

> Earlier versions used javascript to tack the default domain onto the

> unqualified address on To/Cc/Bcc lines in the message composition

> screen.



This request is a duplicate of Ticket #3823.  The bug that was the 
original subject of this ticket has been resolved however.