[#5057] Warnings on index page on login
Summary Warnings on index page on login
Queue Horde Framework Packages
Queue Version HEAD
Type Bug
State Resolved
Priority 3. High
Owners jan@horde.org, slusarz@horde.org
Requester selsky@columbia.edu
Created 2007-03-03 (4877 days ago)
Due
Updated 2007-03-14 (4866 days ago)
Assigned 2007-03-14 (4866 days ago)
Resolved 2007-03-14 (4866 days ago)
Milestone
Patch No

Comments
Matt Selsky <selsky@columbia.edu> 2007-03-03 01:47:56
When I first login to imp, the mailbox index page shows:



Notice: Undefined index: allow_folders in 
/etc/httpd/htdocs/horde/imp/mailbox.php on line 465

Notice: Undefined index: spam in 
/etc/httpd/htdocs/horde/imp/mailbox.php on line 526

Notice: Undefined index: notspam in 
/etc/httpd/htdocs/horde/imp/mailbox.php on line 532



Also the "personal" images are sourced from nag instead of imp...



The problem goes away when the index is refreshed.

Michael Slusarz <slusarz@horde.org> 2007-03-04 22:03:41
Looks like this is the offending commit:

http://lists.horde.org/archives/cvs/Week-of-Mon-20070226/065671.html



Here's what I committed that seems to fix things (at least it makes 
the errors go away and allows me to see the correct graphics):

http://lists.horde.org/archives/cvs/Week-of-Mon-20070226/065719.html



But I am going to assign to Jan since I am unsure if this is the 
correct way to fix or not.

Jan Schneider <jan@horde.org> 2007-03-05 10:50:39
Your fix looks fine, thanks.

Michael Slusarz <slusarz@horde.org> 2007-03-14 08:38:28
This still doesn't work perfectly - now, on logout, the favicon that 
appears on the login page is not correct.

Jan Schneider <jan@horde.org> 2007-03-14 15:50:44
Fixed