[#5] Error adding new addresses
Summary Error adding new addresses
Queue Turba
Queue Version HEAD
Type Bug
State Not A Bug
Priority 2. Medium
Owners
Requester michael@alist.biz
Created 2004-03-12 (6399 days ago)
Due
Updated 2017-10-25 (1424 days ago)
Assigned 2004-03-15 (6396 days ago)
Resolved 2004-03-25 (6386 days ago)
Milestone
Patch No

Comments
michael@alist.biz 2004-03-12 06:13:30
I receive the following error adding new addresses:

   There was an error adding this object. Contact your system 
administrator for further help.



Michael

Jon Parise <jon@horde.org> 2004-03-15 02:16:33
Ask your system administrator to check their logs.  We'll need that 
error information to trace this problem further.



Also, please provide steps that will help us reproduce the problem.   
You report is entirely devoid of context and detail.

jairo.medina@arquicol.com 2004-03-20 12:50:54
Hi. Having the same problem when adding an user to the address book. 
No strage steps, just fill the add user form and then press Enter. I'm 
the administrator of the site but no idea what is going wrong. Please 
let me know what log file do you need so I can send it to you.



Jairo

Jan Schneider <jan@horde.org> 2004-03-20 22:59:29
You configure where your logs are sent in the Horde configuration. If 
you are the administrator you should know where your logs go.

webmaster@upperallenfire.com 2004-03-22 18:43:09
I have this same problem.  I have contacted my web host 
(anhosting.com) who use cPanel and they stated that you (or maybe 
cPanel) is aware of the problem and that they are waiting for an 
update fix.

Chuck Hagenbuch <chuck@horde.org> 2004-03-25 17:16:32
This is not a valid bug; just a configuration problem.

Git Commit <commits@lists.horde.org> 2017-10-25 08:25:48
Changes have been made in Git (master):

commit 56d82c6574bfa544f9fd0515d312eaeb442e632a
Author: Michael Cramer <michael@bigmichi1.de>
Date:   Sun, 22 Oct 2017 14:30:10 +0200

  TypeError: Argument 2 passed to Horde_Db_Adapter_Base::_replaceParameters()

when we do a automatic face detection whit libpuzzle enabled we got an 
error about wrong argument type

2017-10-22T12:17:22+00:00 EMERG: HORDE [ansel] TypeError: Argument 2 
passed to Horde_Db_Adapter_Base::_replaceParameters() must be of the 
type array, integer given, called in 
/usr/share/php/Horde/Db/Adapter/Pdo/Base.php on line 364 and d
efined in /usr/share/php/Horde/Db/Adapter/Base.php:784
Stack trace:
#0 /usr/share/php/Horde/Db/Adapter/Pdo/Base.php(364): 
Horde_Db_Adapter_Base->_replaceParameters('face_id = ?', 5)
#1 /srv/www/docs/ansel/lib/Faces/Base.php(655): 
Horde_Db_Adapter_Pdo_Base->updateBlob('ansel_faces', Array, Array)
#2 /srv/www/docs/ansel/lib/Faces/Base.php(554): 
Ansel_Faces_Base->saveSignature(4947, 5)
#3 /srv/www/docs/ansel/lib/Ajax/Imple/EditFaces.php(50): 
Ansel_Faces_Base->getFromPicture(Object(Ansel_Image), true)
#4 /usr/share/php/Horde/Core/Ajax/Imple.php(120): 
Ansel_Ajax_Imple_EditFaces->_handle(Object(Horde_Variables))
#5 /usr/share/php/Horde/Core/Ajax/Application/Handler/Imple.php(31): 
Horde_Core_Ajax_Imple->handle(Object(Horde_Variables))
#6 /usr/share/php/Horde/Core/Ajax/Application.php(175): 
Horde_Core_Ajax_Application_Handler_Imple->imple()
#7 /srv/www/docs/services/ajax.php(61): 
Horde_Core_Ajax_Application->doAction()
#8 {main} [pid 13479 on line 74 of "/usr/share/php/Horde/ErrorHandler.php"]

  M lib/Faces/Base.php

https://github.com/horde/ansel/commit/56d82c6574bfa544f9fd0515d312eaeb442e632a