[#14891] Kronolith hangs every time
Summary Kronolith hangs every time
Queue Kronolith
Queue Version 4.2.25
Type Bug
State No Feedback
Priority 1. Low
Owners
Requester lameventanas@gmail.com
Created 2019-01-30 (233 days ago)
Due
Updated 2019-03-02 (202 days ago)
Assigned 2019-01-31 (232 days ago)
Resolved 2019-03-02 (202 days ago)
Milestone
Patch No

Comments
lameventanas@gmail.com 2019-01-30 14:09:35
Kronolith causes a runaway process in my server until PHP hits the 
execution time limit.

Whenever I enter the monthly view, the "loading" icon shows 
indefinitely and the Apache process uses 100% of the CPU time.

After some experimentation I could trace it down to one particular 
calendar being enabled.  I have two other calendars (with events) that 
don't cause any problem.

The request that causes the problem is: POST 
/services/ajax.php/kronolith/listEvents


build+horde@de-korte.org 2019-01-30 14:44:05
Before anything else, make sure you're running the latest version from 
PEAR. If the version in this report is correct, at least for Kronolith 
you're 2 releases behind.

lameventanas@gmail.com 2019-01-31 11:34:52
> Before anything else, make sure you're running the latest version 
> from PEAR. If the version in this report is correct, at least for 
> Kronolith you're 2 releases behind.

Believe me, I have been trying to update to the latest version for a 
long time already, but it has been impossible.
First pear.horde.org had an expired certificate, and now pear.php.net 
doesn't work.  So there is no way to update and I don't know when it 
will be possible.

Automatic installation methods in general suck, there is no control.   
There should be a manual option.

Anyway, I filed this report because I was expecting this to be a bug 
due to some recurring event in the database, so maybe we can find it 
out and determine if it is still present in the latest version or not.

Michael Rubinsky <mrubinsk@horde.org> 2019-02-11 05:02:47
Indeed there have been a few of these types of bugs fixed over the 
last year or so.

It sounds like it might be this one: https://bugs.horde.org/ticket/14752



lameventanas@gmail.com 2019-02-12 02:50:09
> It sounds like it might be this one: https://bugs.horde.org/ticket/14752

It's not the same bug.

An event with event_timezone = 'America/New_York' causes the infinite loop.
If I change it to NULL or 'Asia/Tokyo' it doesn't happen.


Michael Rubinsky <mrubinsk@horde.org> 2019-02-12 03:56:28
>> It sounds like it might be this one: https://bugs.horde.org/ticket/14752
>
> It's not the same bug.
>
> An event with event_timezone = 'America/New_York' causes the infinite loop.
> If I change it to NULL or 'Asia/Tokyo' it doesn't happen.

What version is your Horde_Timezone package? You might also try to 
make sure that the timezone data is up to date.



lameventanas@gmail.com 2019-02-12 05:03:17
>>> It sounds like it might be this one: https://bugs.horde.org/ticket/14752
>>
>> It's not the same bug.
>>
>> An event with event_timezone = 'America/New_York' causes the infinite loop.
>> If I change it to NULL or 'Asia/Tokyo' it doesn't happen.
>
> What version is your Horde_Timezone package? You might also try to 
> make sure that the timezone data is up to date.


Horde_Timezone appears to be 1.1.0.

My OS timezone data is version 2018g (2018-10-27).


lameventanas@gmail.com 2019-02-12 06:48:53
Finally pear.php.net is back.
I updated everything to the latest version, problem is still there.

build+horde@de-korte.org 2019-02-12 08:05:45
Did you also upgrade PHP in the mean time?

lameventanas@gmail.com 2019-03-02 15:52:21
> Did you also upgrade PHP in the mean time?

PHP version is 7.2.14.