[#14830] horde-translation does not work anymore on code downloaded via pear
Summary horde-translation does not work anymore on code downloaded via pear
Queue Horde Base
Queue Version 5.2.18
Type Bug
State Unconfirmed
Priority 1. Low
Requester wahnes@uni-koeln.de
Created 2018-07-06 (697 days ago)
Updated 2018-07-29 (674 days ago)
Patch No

wahnes@uni-koeln.de 2018-07-06 11:01:35
With the changes introducted between version 5.2.17 and 5.2.18, the 
/usr/bin/horde-translation script does not work properly when trying 
to generate new MO files from PO files edited locally after a release 
of the Horde package has been downloaded via pear.

Around line 407 of horde-translation, in the strip_horde function, the 
5.2.18 version introduces a reference to Horde_Yaml which the Horde 
pear package does not depend on. With Horde_Yaml installed, the 
strip_horde function still fails as there is no ".horde.yml" file in a 
pear downloaded Horde package.

The code of the strip_horde function in the older version used 
str_replace to do the work, which worked fine in the case that there 
is no git checkout involved.

Michael Rubinsky <mrubinsk@horde.org> 2018-07-29 15:06:49
I'd hesitate to call this a bug. These tools are meant to be used in a 
git checkout. The fact that they worked without one previously was a 
lucky accident...  leaving the ticket open though in case someone has 
some time they are looking to fill....